E90 320 Turbo problems
Results 1 to 5 of 5

Thread: Turbo problems

  1. #1

    Chickenface14's Avatar
    Join Date
    Sep 2016
    Location
    Essex
    Posts
    3
    Car Specs:
    Year
    2006
    Model
    530d 320d
    Engine
    3. 2.
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    Turbo problems

    Good evening and hello to all.

    I'm new to this forum, having been recommended this forum by a friend I'd like to run something by you lot in the hope someone can help. The turbo on my woman's 2006 E90 320d went a couple of weeks ago. She had the whining noise and tons of white smoke also the engine run on after the key was removed for around 40 seconds. I took it off and it was quite obvious that it had gone. I ordered a reconditioned one and put it on today. I cranked it over with the pump relay removed for a long time until I had oil pressure. Then started the engine, it runs ok but when I give it some throttle it's as though it has a very small effect on engine speed, it doesn't really rev at all,it also make a slight noise like a dump valve when the engine is turned off, it'd be appreciated if someone could shed some light on this it'd be appreciated.

    Thank you

  2. #2
    Moderator
    simonsays's Avatar
    Join Date
    Mar 2012
    Location
    Wigan
    Posts
    11,659
    Car Specs:
    Year
    2003
    Model
    E46 Coupe
    Engine
    330i
    Fuel
    Petrol
    Thanks
    12,592
    Thanked 7,120 Times in 5,410 Posts


    Sounds like the variable vanes might not be opening fully ? when you switch the ignition can you see the turbo actuator perform its movement check ?

  3. #3

    Chickenface14's Avatar
    Join Date
    Sep 2016
    Location
    Essex
    Posts
    3
    Car Specs:
    Year
    2006
    Model
    530d 320d
    Engine
    3. 2.
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hi simonsays, thanks for your reply and apologies for my late one I don't get much time in the week, anyway, I've been out there this morning tinkering, I got my mrs to turn the ignition on and I could see the actuator operating. I started the begins and let it tick over for a few minutes then gave it some gentle revs, today it seemed to want to rev to around 2500, then if I gave it a little blip it would rev higher. It then revved itself probably to the redline at which point I had a complete panic and turned it off which didn't kill it straight away, when I lifted the bonnet there was a bit of coolant sprayed about as if the pressure cap had let by. I'm at a bit of a loss at the moment. Could the revving be down to oil in the intercooler from the previous turbo going being sucked in and it's running on that?

    Thanks for your help

    Chris

  4. #4

    Chickenface14's Avatar
    Join Date
    Sep 2016
    Location
    Essex
    Posts
    3
    Car Specs:
    Year
    2006
    Model
    530d 320d
    Engine
    3. 2.
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hi and to add to all this grief the engine just cranks over now, it won't start at all

    Thanks

    Chris

  5. #5
    Moderator
    simonsays's Avatar
    Join Date
    Mar 2012
    Location
    Wigan
    Posts
    11,659
    Car Specs:
    Year
    2003
    Model
    E46 Coupe
    Engine
    330i
    Fuel
    Petrol
    Thanks
    12,592
    Thanked 7,120 Times in 5,410 Posts


    Hi Chris, sorry to hear things appear to have gone worse now the car isn't starting! Certainly removing & cleaning the intercooler won't harm & will give you piece of mind.

    Do you have access to diagnostic equipment?


    Sent from my SM-G925F using Tapatalk

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •