E46 330 E46 330CD M57N engine problem
Results 1 to 5 of 5
  1. #1
    Unverified Member
    jchuillier's Avatar
    Join Date
    Mar 2018
    Location
    france
    Posts
    2
    Car Specs:
    Year
    2006
    Model
    E46
    Engine
    330
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    E46 330CD M57N engine problem

    Hello all,

    Lately my 330CD has been playing games on me, from time to time it seems I don"t have turbo anymore, the engine just accelerates much slower (2nd and 3rd gear) and in a very linear way, then on the next acceleration everything will work fine....

    I also have some very short engine cuts, between 1500 and 2000 rpm, when I release the throttle and let it sort of "idling" when I push the throttle again it gives the feeling that the engine is cutting and then goign again immediatly.

    I suspect an electrical problem since if it was only a turbo related problem it would not cause any problems at 1500-2000 rpm since the turbo "starts" later on.

    Are there any obvious things to look at ?

    Thanks for the help.

  2. #2
    I stopped believing in god when i realised it's just dog backwards.
    BFI Stalwart
    ramshorn's Avatar
    Join Date
    Aug 2012
    Location
    cumbria
    Posts
    566
    Car Specs:
    Year
    2011
    Model
    E90 335i M sport LCI
    Engine
    N55
    Fuel
    Petrol
    Thanks
    234
    Thanked 228 Times in 188 Posts


    check and clean the MAF and MAP sensors, also the EGR valve could be clogged up, all are straightforward to do for a start

  3. #3
    Moderator
    simonsays's Avatar
    Join Date
    Mar 2012
    Location
    Wigan
    Posts
    11,901
    Car Specs:
    Year
    2003
    Model
    E46 Coupe
    Engine
    330i
    Fuel
    Petrol
    Thanks
    12,848
    Thanked 7,184 Times in 5,462 Posts


    Do you have any diagnostic error codes to go off?

    Sent from my SM-G950F using Tapatalk

  4. #4
    Unverified Member
    jchuillier's Avatar
    Join Date
    Mar 2018
    Location
    france
    Posts
    2
    Car Specs:
    Year
    2006
    Model
    E46
    Engine
    330
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hello,

    Thanks for the tips, will try that, is there an easy way to test these sensors except by replacing them ?

    The EGR is "clean"; I did it 6 months ago and it's really and electrical/sensor problem, below 2000 if I'm "lucky" I can get the engine to stutter at a stable RPM.....just like if you had no throttle and then it came back.....

    I'll try this and report, thanks again for the tips

  5. #5
    BFI Noob
    rasa99mw's Avatar
    Join Date
    Nov 2017
    Location
    northumberland
    Posts
    8
    Car Specs:
    Year
    2003
    Model
    E
    Engine
    330d
    Fuel
    diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    you can disconnect the maf sensor,if the car drives to stock settings after the disconnection,then the maf will need changing

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •