E36 M3 Slight misfire hiccup on idle??
Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    BFI Noob
    AlsM3Evo's Avatar
    Join Date
    Sep 2012
    Location
    London
    Posts
    25
    Car Specs:
    Year
    1997
    Model
    Bmw E36 M3 Evo
    Engine
    3.2l
    Fuel
    Petrol
    Thanks
    2
    Thanked 3 Times in 3 Posts


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    Slight misfire hiccup on idle??

    Hi guys I have a small problem with my m3 she is a 97 3.2 evo an I have a slight misfire, wouldnt even call it that but it's a pop from exhaust hiccup and only happens on idle when warm every 15-20 sec iv checked all pipes under manifold and no problem got it on a computer and all was clear no problem there!! Done a vannos test and all fine changed plugs etc! Normal drivin it's fine an power is all there! I'm a bit stuck if anyone can help would be great
    Alex

  2. #2
    Super Moderator
    NealP's Avatar
    Join Date
    Mar 2012
    Location
    Middlesex
    Posts
    2,153
    Car Specs:
    Year
    2006 + 2007
    Model
    E90 325i M Sport + E87 120d
    Engine
    2.5l + 2.0l
    Fuel
    Petrol + Diesel
    Thanks
    526
    Thanked 1,573 Times in 1,071 Posts


    Did you check that the coils were ok when you changed the plugs? No hairline cracks?

  3. #3
    BFI Noob
    AlsM3Evo's Avatar
    Join Date
    Sep 2012
    Location
    London
    Posts
    25
    Car Specs:
    Year
    1997
    Model
    Bmw E36 M3 Evo
    Engine
    3.2l
    Fuel
    Petrol
    Thanks
    2
    Thanked 3 Times in 3 Posts


    Hi Neil, yep checked them through through and they were mint!! Air maf? But that would have shown on the diagnostics ?

  4. #4
    Super Moderator
    NealP's Avatar
    Join Date
    Mar 2012
    Location
    Middlesex
    Posts
    2,153
    Car Specs:
    Year
    2006 + 2007
    Model
    E90 325i M Sport + E87 120d
    Engine
    2.5l + 2.0l
    Fuel
    Petrol + Diesel
    Thanks
    526
    Thanked 1,573 Times in 1,071 Posts


    Is it like a ticking noise coming out from the exhaust?

  5. #5
    BFI Noob
    AlsM3Evo's Avatar
    Join Date
    Sep 2012
    Location
    London
    Posts
    25
    Car Specs:
    Year
    1997
    Model
    Bmw E36 M3 Evo
    Engine
    3.2l
    Fuel
    Petrol
    Thanks
    2
    Thanked 3 Times in 3 Posts


    No it's a pop everytime

  6. #6
    Super Moderator
    NealP's Avatar
    Join Date
    Mar 2012
    Location
    Middlesex
    Posts
    2,153
    Car Specs:
    Year
    2006 + 2007
    Model
    E90 325i M Sport + E87 120d
    Engine
    2.5l + 2.0l
    Fuel
    Petrol + Diesel
    Thanks
    526
    Thanked 1,573 Times in 1,071 Posts


    So it could be a fuel supply problem...possibly injectors or fuel pump.

  7. #7
    Moderator
    simonsays's Avatar
    Join Date
    Mar 2012
    Location
    Wigan
    Posts
    11,872
    Car Specs:
    Year
    2003
    Model
    E46 Coupe
    Engine
    330i
    Fuel
    Petrol
    Thanks
    12,803
    Thanked 7,168 Times in 5,450 Posts


    Didn't @Kevin Whittaker have similar with his vert? Might be wrong but it turned out to be a loose wire or connection?

    Sent from my GT-I9100

  8. #8
    No longer has a car :(
    Moderator
    StK's Avatar
    Join Date
    Mar 2012
    Location
    London - east currently
    Posts
    3,836
    Car Specs:
    Year
    I
    Model
    don't
    Engine
    have a
    Fuel
    car :(
    Thanks
    2,594
    Thanked 2,531 Times in 1,756 Posts


    Another possible cause is when there is a leak on the washer jets it drips onto number 6 cylinder causing a slight misfire......

  9. #9
    BFI Noob
    AlsM3Evo's Avatar
    Join Date
    Sep 2012
    Location
    London
    Posts
    25
    Car Specs:
    Year
    1997
    Model
    Bmw E36 M3 Evo
    Engine
    3.2l
    Fuel
    Petrol
    Thanks
    2
    Thanked 3 Times in 3 Posts


    Fuel pump did cross my mind as iv never changed it before but injectors got cleaned professionally about a year ago. I think that's what il try next but wouldn't it be doing the same with the revs up? But I guess if it's just started it will get worst il give that ago thanks mate

  10. #10
    BFI Noob
    AlsM3Evo's Avatar
    Join Date
    Sep 2012
    Location
    London
    Posts
    25
    Car Specs:
    Year
    1997
    Model
    Bmw E36 M3 Evo
    Engine
    3.2l
    Fuel
    Petrol
    Thanks
    2
    Thanked 3 Times in 3 Posts


    Quote Originally Posted by StK View Post
    Another possible cause is when there is a leak on the washer jets it drips onto number 6 cylinder causing a slight misfire......
    It's all very dry under there I had the sparks out the other day and was all fine there

Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •