E46 330 Aircon/Fog light problem possibly electrical??
Results 1 to 3 of 3
  1. #1
    Enjoying The Rasp
    BFI Hero
    The Panther's Avatar
    Join Date
    Apr 2012
    Location
    Windsor
    Posts
    1,119
    Car Specs:
    Year
    2003
    Model
    M3
    Engine
    S54
    Fuel
    Petrol
    Thanks
    445
    Thanked 551 Times in 376 Posts


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    Aircon/Fog light problem possibly electrical??

    Hi,

    A funny one with my car at the moment, a few problems I'm starting to think are linked.
    So first thing that happened the thermometer was damaged - the OBC now either reads +50 or -40: now when it reads -40 the aircon does not work! At -50 it blows ice cold - is there some kind of system preventing it come on at extremley low temperatures. Very starnge but I'm certain the correlation exists. Also worth noting it seems to only read -40 in the wet
    Also at the same time both fog lights stopped turning on - so I'm thinking maybe water is getting on the electrics somewhere?

    I've no idea really can anyone shed any light on this?

    James

  2. #2
    But you can call me cat-snake.
    Site Admin
    Ferret's Avatar
    Join Date
    Mar 2012
    Location
    Lincolnshire
    Posts
    7,642
    Car Specs:
    Year
    2001
    Model
    E46
    Engine
    330
    Fuel
    Momentum
    Thanks
    4,286
    Thanked 5,095 Times in 3,168 Posts


    Had a similar problem with mine when I ran over my own outside temp' sensor it stripped some wire, and everytime it touched some part of the body it would arc' out (and when it rained it would arc' across the 2 bare wires) and goto -40c then beep at me.

    I've tidied it up, and put electrical tape over the bare wires, and now it only reads +50c even when it rains.

    Aircon won't work below -4c (give or take a few degree's), and it'll get the reading from the outside temp' sensor, and with it thinking the outside temp is -40c, it won't switch on.

    Fix the wiring, so atleast it displays +50c, and your aircon should work. You may find more damaged wires, which could explain the fog light issue !

    HTH

  3. #3
    Enjoying The Rasp
    BFI Hero
    The Panther's Avatar
    Join Date
    Apr 2012
    Location
    Windsor
    Posts
    1,119
    Car Specs:
    Year
    2003
    Model
    M3
    Engine
    S54
    Fuel
    Petrol
    Thanks
    445
    Thanked 551 Times in 376 Posts


    Quote Originally Posted by Ferret View Post
    Had a similar problem with mine when I ran over my own outside temp' sensor it stripped some wire, and everytime it touched some part of the body it would arc' out (and when it rained it would arc' across the 2 bare wires) and goto -40c then beep at me.

    I've tidied it up, and put electrical tape over the bare wires, and now it only reads +50c even when it rains.

    Aircon won't work below -4c (give or take a few degree's), and it'll get the reading from the outside temp' sensor, and with it thinking the outside temp is -40c, it won't switch on.

    Fix the wiring, so atleast it displays +50c, and your aircon should work. You may find more damaged wires, which could explain the fog light issue !

    HTH
    Brilliant makes sense thanks mate - I've wrapped the wire in electical tape but at the moment it's stuck on -40 can't seem to change it!
    Car will be having some work done at some point so will get someone to sort it who is capable.
    I guess a wire to the fogs is damaged too.

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •