E61 525 Power and MPG problem)
Results 1 to 2 of 2
  1. #1
    Unverified Member
    trevorngraham's Avatar
    Join Date
    Sep 2016
    Location
    Kent
    Posts
    2
    Car Specs:
    Year
    2005
    Model
    525d msport touring
    Engine
    525
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    Power and MPG problem)

    Hi all,

    Looking for some help. My 525d msport e61 which I've owned for just over 2 years is driving me mad lol. I've had an issue with turbo lag, power and MPG since buying the car. I'm about to give up on the car and sell it but am having one final push to sort it out.

    Since owning the car, apart from very regular oil changes and servicing I've done the following:-

    Swirl flap removal and blanking kit fitted
    EGR valve cleaned every 5,000 miles or so
    Regular use of DPF cleaner and RedEx injector cleaner
    All 3 thermostats replaced
    K&N Air Filter
    Engine carbon cleaned (3 times in 40,000 miles)
    Glow plug control unit replaced
    Brand new turbo charger fitted
    Remapped with a reputable company
    Replaced fuel filter
    Replaced fuel heater

    After all of this, it still doesn't seem to run right and was lacking a bit of power, making an air whooshing sound, slight turbo lag and in and out of limp mode (most annoying). It's booked back into a local specialist independent garage today for a couple of O2 sensors to be replaced, the intercooler pipe to the EGR valve has a split and that's being replaced too (seems you can't just replace the rubber part, it's the whole pipe right from the intercooler to the EGR valve). One of the drive belts is also looking frayed and cracked so that's being done at the same time.

    I've tried unplugging the MAF to check it's working and it would appear to be fine (I cleaned it anyway).

    So, my question is really is it time to get shot or is there anything else that from experience anyone can also suggest?

    With the car unloaded, and driven at 70mph on the motorway, I'm only seeing 34mpg. Temp seems fine - 90oC plus (accessed via hidden menu). When I stop the car, the only thing I have noticed is that the car smells (and sounds) really 'hot' if that makes any sense.

    Thanks in advance from a frustrated 525d owner lol

  2. #2
    BFI Apprentice
    ///M's Avatar
    Join Date
    Dec 2015
    Location
    MK
    Posts
    30
    Car Specs:
    Year
    05
    Model
    E60
    Engine
    530d
    Fuel
    Diesel
    Thanks
    1
    Thanked 3 Times in 3 Posts


    exhaust manifold is prone to cracking, have you checked that?

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •