E83 X3 2.0 Sudden misfire and total power loss at random
Results 1 to 2 of 2
  1. #1
    Unverified Member
    peterx3eastcoast's Avatar
    Join Date
    Apr 2018
    Location
    Norfolk
    Posts
    3
    Car Specs:
    Year
    2010
    Model
    E83
    Engine
    20d
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    Sudden misfire and total power loss at random

    I Have an X3 20d Xdrive 2010 N47D20C. Its been fine with no issues just ran over 60000 mls. As a totally random occurrence it will loose power and feel if it were a petrol engine like a miss fire enough to have to pull over stop and wait. Sometimes just waiting it fines its self again other times turn off and restart.
    There are no bad noises no mpg changes no white some or oil/water consumption, I have this time had the engine management light come on and the codes are 40E9 4B81 and 4B82. If i clear these codes it can be a week or more before I get the same issue.
    Any ideas anybody had a similar issue it would be nice to know if you fixed it cheers.

  2. #2
    BFI Hero
    Mike320msport's Avatar
    Join Date
    Aug 2013
    Location
    Teesside
    Posts
    1,134
    Car Specs:
    Year
    2007
    Model
    320i msport
    Engine
    2.0
    Fuel
    petrol
    Thanks
    272
    Thanked 345 Times in 297 Posts


    Only thing I could find for these codes points to an EGR related fault. Would do some more research before going down this route or at least give it a clean and see if that sorts it.

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •