E53 X5 4.4 554c DSC inactive light
Results 1 to 2 of 2
  1. #1
    Unverified Member
    LarryBoyG's Avatar
    Join Date
    Jun 2018
    Location
    Indiana
    Posts
    2
    Car Specs:
    Year
    2006
    Model
    E53
    Engine
    N62
    Fuel
    Petrol
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    554c DSC inactive light

    Hello Everyone,

    Just rolled over 118000 on 06 x5 with the 4.4 N62. I had both valve covers done with new spark plugs and the truck drives like brand new. Recently i got a 4x4 light on the dash, with no other lights. it still seams to have abs but haven't really tested it. Wouldn't the ABS light be on with it? I test it with INPA and it can't find the DSC module and when connecting to the gearbox it has code 55C4 (unable to communicate with DSC). The DSC button is unresponsive. I connected with ISTA D and the DSC Module is greyed out. Afterwards, I connected with ISTA P and was able to connect to DSC and reprogram it but no change afterwards. 4x4 light is still on. Also would a weak battery cause this. I ask because the battery does hold a charge and the alt is working. Checking with ISTA it outputs 14.5 volts but the battery dies really quick. 15 minutes with door open.

    Any help is appreciated.

    Thanks

  2. #2
    Unverified Member
    FREEBUSINESSES's Avatar
    Join Date
    Jul 2018
    Location
    NY
    Posts
    2
    Car Specs:
    Year
    03
    Model
    X5
    Engine
    4.4
    Fuel
    gas
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Quote Originally Posted by LarryBoyG View Post
    Hello Everyone,

    Just rolled over 118000 on 06 x5 with the 4.4 N62. I had both valve covers done with new spark plugs and the truck drives like brand new. Recently i got a 4x4 light on the dash, with no other lights. it still seams to have abs but haven't really tested it. Wouldn't the ABS light be on with it? I test it with INPA and it can't find the DSC module and when connecting to the gearbox it has code 55C4 (unable to communicate with DSC). The DSC button is unresponsive. I connected with ISTA D and the DSC Module is greyed out. Afterwards, I connected with ISTA P and was able to connect to DSC and reprogram it but no change afterwards. 4x4 light is still on. Also would a weak battery cause this. I ask because the battery does hold a charge and the alt is working. Checking with ISTA it outputs 14.5 volts but the battery dies really quick. 15 minutes with door open.

    Any help is appreciated.

    Thanks
    If battery dies this quickly, replace it, and when you do, then verify if ABS is working by getting on grass or loose gravel and hit brakes, voltage issues can cause very strange issues I have found.

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •