6 glow plugs errors again and again
Results 1 to 5 of 5
  1. #1
    Unverified Member
    Bmwe61's Avatar
    Join Date
    Jan 2017
    Location
    London
    Posts
    3
    Car Specs:
    Year
    2004
    Model
    E61
    Engine
    2.5
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    6 glow plugs errors again and again

    Hi, everyone, been having some problems with my car, i would say it's a curse. Changed 6 glow plugs and module all Beru, deleted all faults and still scanner is showing errors for 6 glow plugs, checked fuses in ebox under bonnet, no burned ones found. Running out of options what could it be, anyone had similar problems, any advice, please. Thanks

  2. #2
    I stopped believing in god when i realised it's just dog backwards.
    BFI Stalwart
    ramshorn's Avatar
    Join Date
    Aug 2012
    Location
    cumbria
    Posts
    556
    Car Specs:
    Year
    2011
    Model
    E90 335i M sport LCI
    Engine
    N55
    Fuel
    Petrol
    Thanks
    234
    Thanked 223 Times in 184 Posts


    module needs to be coded to the car?

  3. #3
    Unverified Member
    j4weeson's Avatar
    Join Date
    Jan 2017
    Location
    Belfast
    Posts
    6
    Car Specs:
    Year
    2006
    Model
    E90
    Engine
    320
    Fuel
    Diesel
    Thanks
    0
    Thanked 0 Times in 0 Posts


    I have similar problem with my e90. Shows all 4 glow plug errors and i replaced with beru parts including module and still have the errors present. I also have the 46D1 Control Unit Internal Error 4 so it could mean my DDE is faulty ?

  4. #4
    Unverified Member
    tdibooster's Avatar
    Join Date
    Sep 2017
    Location
    scotland
    Posts
    6
    Car Specs:
    Year
    2000
    Model
    e46
    Engine
    330d
    Fuel
    diesel
    Thanks
    0
    Thanked 2 Times in 2 Posts


    module doesnt need coded if its prefcelift ie:just the control relay beside dde. when you go thru testing relay etc in DIS do you hear the relay clicking? If so then that means the module/relay is doing its job. that leaves the signal wire to relay in order to power the glowplugs. time to get multimeter out.

  5. #5
    Unverified Member
    tdibooster's Avatar
    Join Date
    Sep 2017
    Location
    scotland
    Posts
    6
    Car Specs:
    Year
    2000
    Model
    e46
    Engine
    330d
    Fuel
    diesel
    Thanks
    0
    Thanked 2 Times in 2 Posts


    have you checked the main fuse also? If relay isnt clicking then as i said its either signal wire or not getting voltage.my glowplug fuse is behind my glovebox(fuse tray has to be removed,its behind that tray).

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •