New BMW owner E91 Fife
Results 1 to 5 of 5
  1. #1
    BFI Noob
    gary4482's Avatar
    Join Date
    Apr 2017
    Location
    glenrothes
    Posts
    15
    Car Specs:
    Year
    2009
    Model
    E91
    Engine
    320
    Fuel
    diesel
    Thanks
    0
    Thanked 1 Time in 1 Post


    Donate Please click the
    image to support
    BMWForums.info
    Click Here To Contribute To Our Site

    New BMW owner E91 Fife

    Hello all.

    New to BMW's and the forum. I say new but I bought it in December, I fear it's an absolute turd and stumbled across this forum whilst looking for parts to repair the turd.

    Thought i'd introduce myself before harassing Harry Fairbairn for parts.

    Hi, I'm Gary

  2. #2
    Moderator
    simonsays's Avatar
    Join Date
    Mar 2012
    Location
    Wigan
    Posts
    11,703
    Car Specs:
    Year
    2003
    Model
    E46 Coupe
    Engine
    330i
    Fuel
    Petrol
    Thanks
    12,636
    Thanked 7,128 Times in 5,416 Posts


    Hi Gary & welcome to BFi

    Sounds like the new E91 has given you some grief

    Sent from my SM-G925F using Tapatalk

  3. #3
    BFI Hero
    Mike320msport's Avatar
    Join Date
    Aug 2013
    Location
    Teesside
    Posts
    1,122
    Car Specs:
    Year
    2007
    Model
    320i msport
    Engine
    2.0
    Fuel
    petrol
    Thanks
    268
    Thanked 344 Times in 296 Posts


    what problems are you having ?
    where did you buy it ?

  4. #4
    BFI Noob
    gary4482's Avatar
    Join Date
    Apr 2017
    Location
    glenrothes
    Posts
    15
    Car Specs:
    Year
    2009
    Model
    E91
    Engine
    320
    Fuel
    diesel
    Thanks
    0
    Thanked 1 Time in 1 Post


    Hi Mike. I bought it privately from a guy in York.

    The rear wiper doesn't work, pivot totally seized and won't move, also seriously stuck into the window so can't replace as yet.

    The rear tailgate window wont open anymore.

    I've a "rear brake pad sensor" message despite pads being like new.
    The under tray has come away from the front bumper and makes an awful noise above 80mph
    Most worryingly though, the front bumper is a totally different shade of white from the rest of the car, annoyed at myself I didn't notice it but it was a cold, wet, dull December day in York. Not sure if it's indicative of an accident and bad repair or just a poor paint job to cover up stone chips.
    I've also convinced myself that one of the rear quarter panels is a different colour too.

    Panoramic roof works though.


    Sent from my iPhone using Tapatalk

  5. #5
    BFI Hero
    Mike320msport's Avatar
    Join Date
    Aug 2013
    Location
    Teesside
    Posts
    1,122
    Car Specs:
    Year
    2007
    Model
    320i msport
    Engine
    2.0
    Fuel
    petrol
    Thanks
    268
    Thanked 344 Times in 296 Posts


    Under tray held in place with screws so should be an easy fix.
    i think the sensors are best replaced with the pads so might be worth a look, don't know if the system auto resets when the pads/sensors are replaced or if you can do it via your dash stalk buttons like you do when the mot etc has been done.
    I think most plastic bumpers look slightly different colour on all cars, if painted and no other signs probably due to chips as they all seem to pick up those.
    rear wiper motor might be seized - check for power to it, try a breakers for a new motor

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •